三层交换机路由配置:
interface Vlanif2 //此为PC1的网关
ip address 192.168.1.254 255.255.255.0
interface Vlanif12 //此为交换机1和2的直连路由
ip address 1.1.1.1 255.255.255.252
interface GigabitEthernet0/0/1
port link-type access
port default vlan 2
interface GigabitEthernet0/0/2
port link-type trunk
port trunk allow-pass vlan 2 5 12
ip route-static 3.3.3.2 255.255.255.252 1.1.1.2
扩展资料:
三层交换机的注意事项:
要说三层交换机在诸多网络设备中的作用,用“中流砥柱”形容并不为过。在校园网、城域教育网中,从骨干网、城域网骨干、汇聚层都有三层交换机的用武之地,尤其是核心骨干网一定要用三层交换机,否则整个网络成千上万台的计算机都在一个子网中,不仅毫无安全可言,也会因为无法分割广播域而无法隔离广播风暴。
如果采用传统的路由器,虽然可以隔离广播,但是性能又得不到保障。而三层交换机的性能非常高,既有三层路由的功能,又具有二层交换的网络速度。二层交换是基于MAC寻址,三层交换则是转发基于第三层地址的业务流;除了必要的路由决定过程外,大部分数据转发过程由二层交换处理,提高了数据包转发的效率。
三层交换机通过使用硬件交换机构实现了IP的路由功能,其优化的路由软件使得路由过程效率提高,解决了传统路由器软件路由的速度问题。因此可以说,三层交换机具有“路由器的功能、交换机的性能”。
参考资料来源:百度百科-三层交换机
你貌似在用HW-RouteSim 在做实验
参考下面的配置和图吧
实验九 静态路由实验
PCA:10.65.1.1 PCB:10.66.1.1 PCC:10.70.1.1 PCD:10.71.1.1
[RouterA]interface ethernet0
[RouterA-Ethernet0]ip addrress 10.65.1.2 255.255.0.0
[RouterA-Ethernet0]undo shutdown
[RouterA-Ethernet0]int e1
[RouterA-Ethernet1]ip addrress 10.66.1.2 255.255.0.0
[RouterA-Ethernet1]undo shutdown
[RouterA-Ethernet1]int s1
[RouterA-Serial1]ip addrress 10.68.1.2 255.255.0.0
[RouterA-Serial1]undo shutdown
[RouterA-Serial1]clock rate 64000
[RouterA-Serial1]quit
[RouterA]ip routing
[RouterA]dis curr
[RouterB]interface ethernet0
[RouterB-Ethernet0]ip addrress 10.70.1.2 255.255.0.0
[RouterB-Ethernet0]undo shutdown
[RouterB-Ethernet0]int e1
[RouterB-Ethernet1]ip addrress 10.71.1.2 255.255.0.0
[RouterB-Ethernet1]undo shutdown
[RouterB-Ethernet1]int s0
[RouterB-Serial0]ip addrress 10.68.1.1 255.255.0.0
[RouterB-Serial0]undo shutdown
[RouterB-Serial0]quit
[RouterB]ip routing
[RouterB]dis curr
[root@PCA root]#ifconfig eth0 10.65.1.1 netmask 255.255.0.0
[root@PCA root]#route add default gw 10.65.1.2
[root@PCA root]#ping 10.65.1.2 通
[root@PCA root]#ping 10.66.1.2 通
[root@PCA root]#ping 10.67.1.2 通
[root@PCA root]#ping 10.68.1.2 不通
[root@PCA root]#ping 10.69.1.2 不通
[RouterA]ip route-static 10.69.0.0 255.255.0.0 10.67.1.1
[root@PCA root]#ping 10.69.1.1 通
三个路由器的静态路由 (参考实验九图)
设置RouterA的IP:
f0/0: 10.65.1.2 --->PCA:10.65.1.1
f0/1: 10.66.1.2 --->PCB:10.66.1.1
s0/0: 10.67.1.2
s0/1: 10.68.1.2 --->接RouterC s0/0
设置RouterC的IP:
s0/0: 10.68.1.1 <---
s0/1: 10.78.1.2 --->接RouterB s0/0
设置RouterB的IP:
s0/0: 10.78.1.1 <---
s0/1: 10.67.1.1
f0/0: 10.69.1.2 --->PCC:10.69.1.1
f0/1: 10.70.1.2 --->PCD:10.70.1.1
设置从PCA到PCC的静态路由
[ROA]ip routing
[ROA]ip route-static 10.69.0.0 255.255.0.0 10.68.1.1
[ROA]display ip route
[ROB]ip route-static 10.69.0.0 255.255.0.0 10.78.1.1
[ROB]display ip route
[root@PCA root]#ping 10.69.1.1 (通)
[root@PCA root]#ping 10.78.1.1 (不通)
[root@PCA root]#ping 10.70.1.1 (不通)
为什么PCA 到10.78.1.1不通呢?它是去10.69.1.1要经过的地方啊,这是由于在
RouterA上,没有去10.78.0.0网络的路由,所以到这个网络它不知道要向哪去送。
如何让PCA到10.70.1.1 (PCD)通呢,像10.69.0.0网络一样,在路径的路由器上
,
再各写一条到10.70.0.0网络的静态路由就可以了。
如果每一条路径都写一组静态路由显然不好,由于PCA在这个网络中实际只有一条
主通路,所以使用默认路由较好。
我们再做一个使用默认路由的小实验,先去掉原有的静态路由。
[ROA]undo ip route-static 10.69.0.0 255.255.0.0 10.68.1.1
[ROA]display ip route
[ROA]undo ip route-static 10.69.0.0 255.255.0.0 10.78.1.1
[ROB]display ip route
[root@PCA root]#ping 10.69.1.1 (不通)
[ROA]ip route-static 0.0.0.0 0.0.0.0 10.68.1.1
[ROB]display ip route
[ROB]ip route-static 0.0.0.0 0.0.0.0 10.69.1.1
[ROB]display ip route
[root@PCA root]#ping 10.69.1.1 (通)
[root@PCA root]#ping 10.70.1.1 (通)
[root@PCA root]#ping 10.78.1.1 (通)
路由表是路由器实现路由的指导思想。到一个网络通不通,要看路由表中有没有去
目的网络的路由表项,动态路由可以自动创建路由表,定时更新。
[RouterB-Serial0]undo ip addrress 10.67.1.1 255.255.0.0
[RouterB-Serial0]ip addrress 10.70.1.1 255.255.0.0
[RouterC]interface serial0
[RouterC-Serial0]ip addrress 10.67.1.1 255.255.0.0
[RouterC-Serial0]undo shutdown
[RouterC-Serial0]clock rate 64000
[RouterC-Serial0]int s1
[RouterC-Serial1]ip addrress 10.70.1.1 255.255.0.0
[RouterC-Serial1]undo shutdown
[RouterC-Serial1]quit
[RouterC]ip route-static 10.69.0.0 255.255.0.0 10.70.1.1
[RouterC]dis curr
[root@PCA root]#ping 10.69.1.1 通
[root@PCA root]#ping 10.68.1.1 不通