交换机的基本命令

2024-12-11 20:49:12
推荐回答(3个)
回答1:

交换机的基本命令有以下四种:
一、模式命令:
1. 用户模式:Switch>
2. 特权模式:Switch>enable
Switch#
3. 全局配置模式:Switch#config terminal
Switch(config)#
4. 接口配置模式:Switch(config)#interface fastethernet0/1
Switch(config-if)#
5. Line模式:Switch(config)#line console 0
Switch(config-line)#
二、特权模式下的命令:
1. 查看机MAC地址:Switch#show mac-address-table
2. 发现(CDP):
Switch#show cdp
Switch#show cdp interface fastethernet0/1
Switch#show cdp neighbors
Switch#show cdp neighbors detail
Switch#show cdp entry
3. 保存机配置:
Switch#copy running-config startup-config或者Switch#write
4. 恢复交换机出厂值:
Switch#erase startup-config
Switch#reload
三、全局配置模式下的命令:
1. 配置主机名:Switch(config)#hostname Sw1
Sw1(config)#
2、 设置登陆台密码:Switch(config)#line console 0
Switch(config-line)#password 密码
Switch(config-line)#login
3. 使能口令:Switch(config)#enable Password 密码
4. 加密保存的使能口令:Switch(config)#enable secret 密码
5. 配置IP地址:
Switch(config)#interface vlan 1
Switch(config-if)#ip address IP地址 网关
Switch(config-if)#no shutdown
6. 配置交换机网关:Switch(config)#ip default-gateway 网关
四、VLAN配置命令:
1. 创建vlan命令:
a) 全局配置模式下:
Switch(config)#vlan 2
Switch(config)#name v2
Switch(config)#mtu 数值
Switch(config)#end
b) Vlan数据库下:
Switch#vlan database
Switch#vlan 2 name v2
Switch#vlan 2 mut 数值
Switch#exit
2. 删除vlan命令:
a) 全局配置模式下:
Switch(config)#no vlan 2
Switch(config)#end
b) Vlan数据库下:
Switch#no vlan 2 name v2
Switch#exit
3. 在vlan中添加端口:
Switch#config terminal
Switch(config)#interface f0/1(端口)
Switch(config-if)#Switchport mode access
Switch(config-if)#switchport access vlan 2
Switch(config-if)#end
一次将多个端口添加到vlan中:
Switch#config terminal
Switch(config)#interface range f0/1 - 5(端口)
Switch(config-if)#switchport access vlan 2
Switch(config-if)#end
注:switch#show vlan biref(查看vlan信息)
4. 配置vlan trunk:
1. 配置接口为trunk命令:
Switch(config)# interface f0/1(端口)
Switch(config-if)#Switchport mode trunk
2. 配置接口为动态协商模式的命令:
Switch(config)# interface f0/1(端口)
Switch(config-if)#switchport mode dynamic desirable/auto
3. 从trunk中删除vlan:
Switch(config)# interface f0/1(端口)
Switch(config-if)#Switchport trunk allowed vlan remove 2
4. 在trunk中添加vlan:
Switch(config)# interface f0/1(端口)
Switch(config-if)#Switchport trunk allowed vlan add 2

回答2:

交换机的启动及基本配置
1924交换机上配置

sw1924_b#delete nvram
全部清除交换机的所有配置
sw1924_b#reload
重新启动交换机(初始提示符为> )
sw1924_b#hostname sw1924
设置交换机的主机名
sw1924_b#enable secret cisco
设置加密密码
sw1924_b#enable password level 1 cisco1
设置等级密码(1最低)
sw1924_b#enable password level 15 cisco15
设置等级密码(15最高)
sw1924_b#ip address 192.168.14.1 255.255.255.0
设置交换机的管理IP地址
sw1924_b#ip default-gateway 192.168.198.2
设置交换机的网关地址
sw1924_b#ip domain-name pctc.com.cn
设置交换机所连域的域名
sw1924_b#ip name-server 218.87.18.230
设置交换机所连域的域名服务器IP
sw1924_b#show ip
查看上述设置环境
sw1924_b#show version
查看交换机的版本等信息
sw1924_b#show running-config
查看交换机的当前运行配置等全部信息
sw1924_b#show int e0/1
查看交换机的第1个端口信息

1924交换机配置端口属性

sw1924_b#conf t
sw1924_b#interface ethernet 0/1
进入第1个端口
sw1924_b#description sw1924_b-e0/1-pc1
给端口写入注释信息
sw1924_b#duplex auto/full/full-flow-control/half
设置端口的工作模式
sw1924_b#port secure
启用端口安全性
sw1924_b#port secure max-mac-count 1
设置该端口允许对应的MAC地址数(默认132个)
sw1924_b#sh mac-address-table security
查看端口安全性

sw1912_a#conf t
进入全局配置模式
sw1912_a#interface fastethernet 0/1
进入第1个端口
sw1912_a#description sw2912_a-f0/1-pc1
给端口写入注释信息
sw1912_a#duplex auto/full/half
设置端口的工作模式
sw1912_a#port security
启用端口安全性
sw1912_a#port security max-mac-count 1
设置该端口允许对应的MAC地址数(默认132个)
sw1912_a#end
返回特权模式
sw1912_a#sh port security
查看端口安全性

配置和查看MAC地址表

1924交换机配置MAC地址表

sw1924_b#mac-address-table aging-time 600
设置动态地址超时时间
sw1924_b#mac-address-table permanent 0000.0cdd.5a4d e0/3
定义永久MAC地址(绑定MAC地址)
sw1924_b#mac-address-table restricted static 0000.0cdd.aaed e0/6 e0/7
定义受限MAC地址
sw1924_b#address-violation disable/ignore/suspend
定义地址安全违规
sw1924_b#show mac-address-table
查看上述配置
sw1924_b#clear mac-addr restric static
清除受限MAC地址表项

2912交换机配置MAC地址表

sw2912_a#mac-address-table aging-time 700
设置动态地址超时时间
sw2912_a#mac-address-table static 0000.0cdd.5a4d e0/3
定义永久MAC地址(绑定MAC地址)
sw2912_a#mac-address-table secure 00d0.f80d.3333 f0/3 vlan 1
定义受限MAC地址
sw2912_a#port security action shutdown/trap
定义地址安全违规
sw2912_a#show port security
查看上述配置

配置VTP、VLAN、VLAN Trunk和STP

配置VTP

sw1924_a#conf t
sw1924_a#vtp server
定义VTP的工作模式
sw1924_a#vtp domain cisco
定义VTP的域名
sw1924_a#trunk on
启用干道

sw1924_b#vtp domain cisco
加入VTP域
sw1924_b#vtp client
定义VTP的工作模式
sw1924_b#trunk on
启用干道

sw1924_a#show trunk b
sw1924_a#show trunk b allowed-vlans
查看干道信息

配置VLAN

sw1924_a#vlan 10 dept1
sw1924_a#vlan 20 dept2
sw1924_a#vlan 30 dept3
sw1924_a#vlan 40 dept4
定义所需VLAN
sw1924_a#show vlan
查看VLAN信息

sw1924_b#show vlan
sw1924_b#show vtp
查看VTP的信息
sw1924_b#int e0/1
sw1924_b#vlan-membership static 10
sw1924_b#int e0/2
sw1924_b#vlan-membership static 20
sw1924_b#int e0/3
sw1924_b#vlan-membership static 30
sw1924_b#int e0/4
sw1924_b#vlan-membership static 40
把接口划入各自VLAN

配置spanning tree

sw1924_b#spantree 1
启用生成树协议
sw1924_b#sh spantree 1
查看生成树信息
sw1924_b#no spantree 1
关闭生成树协议
sw1924_b#sh spantree 1
查看生成树信息

回答3: